Difference between revisions of "Category:Installation"

From Open Babel
Jump to: navigation, search
m (Typo)
(Updates links to OB user docs instead of wiki)
Line 13: Line 13:
 
:: [http://openbabel.org/docs/2.3.0/GUI/GUI.html Documentation]
 
:: [http://openbabel.org/docs/2.3.0/GUI/GUI.html Documentation]
  
* '''[[Python | Python module]]''' (requires OpenBabelGUI above)
+
* '''[http://openbabel.org/docs/2.3.0/UseTheLibrary/Python.html Python module]''' (requires OpenBabelGUI above)
 
: Provides access to the Open Babel libraries from Python. The current version is 1.6.
 
: Provides access to the Open Babel libraries from Python. The current version is 1.6.
* '''[[Java | Java library]]''' (requires OpenBabelGUI above)
+
* '''[http://openbabel.org/docs/2.3.0/UseTheLibrary/Java.html Java library]''' (requires OpenBabelGUI above)
 
: Provides access to the Open Babel libraries from Java.
 
: Provides access to the Open Babel libraries from Java.
* '''[[OBDotNet | OBDotNet assembly]]'''
+
* '''[http://openbabel.org/docs/2.3.0/UseTheLibrary/CSharp.html OBDotNet assembly]''' (requires OpenBabelGUI above)
 
: Provides access to the Open Babel libraries from .NET languages.
 
: Provides access to the Open Babel libraries from .NET languages.
  
Line 25: Line 25:
 
:: [http://sourceforge.net/projects/openbabel/files/openbabel/2.3.0/openbabel-2.3.0.tar.gz/download Download 2.3.0 stable release]  
 
:: [http://sourceforge.net/projects/openbabel/files/openbabel/2.3.0/openbabel-2.3.0.tar.gz/download Download 2.3.0 stable release]  
 
:: or [[Subversion | Get latest development code]]
 
:: or [[Subversion | Get latest development code]]
:: [[Install_(MSVC) | Instructions for MSVC++]]
+
:: [http://openbabel.org/docs/2.3.0/Installation/install.html#compiling-open-babel Compile instructions]
:: [[Install_(Cygwin) | Instructions for Cygwin]]
+
:: Open Babel can be compiled using any of MSVC++, Cygwin or MinGW
:: [[Install_(MinGW) | Instructions for MinGW]]
+
 
</div>
 
</div>
 
| width="30%" class="MainPageBG" style="border: 1px solid #FFC435; background-color: #f8fff8; vertical-align:top;"|
 
| width="30%" class="MainPageBG" style="border: 1px solid #FFC435; background-color: #f8fff8; vertical-align:top;"|
Line 37: Line 36:
 
:: [http://sourceforge.net/projects/openbabel/files/openbabel/2.3.0/openbabel-2.3.0.tar.gz/download Download 2.3.0 stable release]  
 
:: [http://sourceforge.net/projects/openbabel/files/openbabel/2.3.0/openbabel-2.3.0.tar.gz/download Download 2.3.0 stable release]  
 
:: or [[Subversion | Get latest development code (today)]]  
 
:: or [[Subversion | Get latest development code (today)]]  
:: [[Install_(source code) | How to compile]]
+
:: [http://openbabel.org/docs/2.3.0/Installation/install.html#compiling-open-babel How to compile]
:: [[Guides | How to use babel and other tools]]
+
:: How to use [http://openbabel.org/docs/2.3.0/Command-line_tools/babel.html obabel]
:: [[Develop | How to develop with Open Babel]]
+
:: [http://openbabel.org/docs/2.3.0/UseTheLibrary/intro.html How to develop with Open Babel]
 
: Scripting language modules:
 
: Scripting language modules:
:: [[Perl]], [[Python]], [[Ruby]], [[Java]], [[OBDotNet | Mono]]
+
:: [http://openbabel.org/docs/2.3.0/UseTheLibrary/Perl.html Perl], [http://openbabel.org/docs/2.3.0/UseTheLibrary/Python.html Python], [http://openbabel.org/docs/2.3.0/UseTheLibrary/Ruby.html Ruby], [http://openbabel.org/docs/2.3.0/UseTheLibrary/Java.html Java], [http://openbabel.org/docs/2.3.0/UseTheLibrary/CSharp.html Mono]
 
<center>or</center>
 
<center>or</center>
 
* '''Install a binary package'''
 
* '''Install a binary package'''

Revision as of 07:25, 1 December 2010

Open Babel is available for Windows, Linux and Macintosh.


Windows

  • OpenBabelGUI
Provides a graphical user interface for Open Babel, as well as a command-line interface. This is what most users are looking for.
Download v2.3.0 Installer
Documentation
Provides access to the Open Babel libraries from Python. The current version is 1.6.
Provides access to the Open Babel libraries from Java.
Provides access to the Open Babel libraries from .NET languages.


The following options are only recommended for experienced developers.

  • Compile from source
Download 2.3.0 stable release
or Get latest development code
Compile instructions
Open Babel can be compiled using any of MSVC++, Cygwin or MinGW

Linux

  • Compile from source
Compile Open Babel:
Download 2.3.0 stable release
or Get latest development code (today)
How to compile
How to use obabel
How to develop with Open Babel
Scripting language modules:
Perl, Python, Ruby, Java, Mono
or
  • Install a binary package
Several Linux distributions provide binary packages. Some of these are more up-to-date than others.
Debian, Fedora, Ubuntu
Other RPM packages
Binary packages for scripting language modules may be named 'openbabel-perl', 'openbabel-python' or 'python-openbabel'

Macintosh

A graphical interface to Open Babel.

To get the command-line tools you need to choose one of the following:

Compile Open Babel using Apple's Developer Tools

Subcategories

This category has the following 3 subcategories, out of 3 total.

Pages in category "Installation"

The following 5 pages are in this category, out of 5 total.